现象
进入 redis-cli,输入命令时,报错信息为(error) NOAUTH Authentication required,如下图所示,这个是因为 redis 客户端开启了密码,需要进行认证才能进入
原因
在 redis 的 conf 文件中设置了密码。
打开 redis.conf,可以找到如下内容,这个是要求验证用户,马赛克的地方就是要求输入的密码。
解决方案
方案一:
打开redis-cli时输入密码,进行认证
/usr/local/redis/bin/redis-cli -h 127.0.0.1 -p 6379 -a Password
方案二
不输密码进入 redis-cli 后,单独在认证密码

C_API
在使用hiredis时,如果不验证,也会出现如上的错误,
解决方案如方案二一样,在连接 redis 后,先执行认证命令,再进行数据访问即可。

